愛查股網 www.suo-yin.cn 股票查詢最好股票網 個股數據查詢好股網 手機APP下載 | 手機訪問 | 加入收藏 | 保存到桌面
愛查股網
股票查詢最好股票網 個股數據查詢好股網
您的位置:愛查股網 > 股票公式 > 通達信公式
股票公式搜索:

通達信跌無可跌選股指標公式

2021/8/24 19:48:13

X_1:=REF(EVERY(CLOSE<OPEN,2),1) AND CLOSE>OPEN;
X_2:=MA(CLOSE,5);
X_3:=MA(CLOSE,10);
X_4:=(X_2-CLOSE)/CLOSE>3/100;
X_5:=(X_3-X_2)/X_2>0.03;
X_6:=LLV(CLOSE,30)=LLV(CLOSE,120);
X_7:=X_4 AND X_5 AND X_6;
X_8:=COUNT(CLOSE/REF(CLOSE,1)>1.097,60) AND (MA(CLOSE,250)>=REF(MA(CLOSE,250),30) OR CLOSE>MA(CLOSE,250)) AND BARSCOUNT(CLOSE)>100;
X_9:=BARSLAST(X_7)<=2 AND X_1 AND X_8;
X_10:=MA(HHV(HIGH,485),17);
X_11:=MA(HHV(HIGH,222),17);
X_12:=MA(HHV(HIGH,96),17);
X_13:=MA(LLV(LOW,485),17);
X_14:=MA(LLV(LOW,222),17);
X_15:=MA(LLV(LOW,96),17);
X_16:=MA((X_13*0.96+X_14*0.96+X_15*0.96+X_10*0.558+X_11*0.558+X_12*0.558)/6,17);
X_17:=MA((X_13*1.25+X_14*1.23+X_15*1.2+X_10*0.55+X_11*0.55+X_12*0.65)/6,17);
X_18:=MA((X_13*1.3+X_14*1.3+X_15*1.3+X_10*0.68+X_11*0.68+X_12*0.68)/6,17);
X_19:=MA((X_16*3+X_17*2+X_18)/6*1.738,17);
X_20:=IF(1<=1341231,X_19,X_19*DAY);
X_21:=LOW;
X_22:=REF(LOW,1);
X_23:=SMA(ABS(X_21-X_22),3,1)/SMA(MAX(X_21-X_22,0),3,1)*100;
X_24:=MA(IF(CLOSE*1.35<=X_20,X_23*10,X_23/10),3);
X_25:=LLV(LOW,30);
X_26:=HHV(X_24,30);
X_27:=13412319;
X_28:=IF(1<=X_27,MA(IF(LOW<=X_25,(X_24+X_26*2)/2,0),3),100000000);
X_29:=REF(X_28,2)>REF(X_28,3) AND X_28<REF(X_28,1);
X_9 AND X_29;


愛查 股網 www.aichagu. com

[源碼注釋]通達信公式動態翻譯結果
X_1賦值:1日前的最近2日一直存在收陰線 AND 收陽線
X_2賦值:收盤價的5日簡單移動平均
X_3賦值:收盤價的10日簡單移動平均
X_4賦值:(X_2-收盤價)/收盤價>3/100
X_5賦值:(X_3-X_2)/X_2>0.03
X_6賦值:30日內收盤價的最低值=120日內收盤價的最低值
X_7賦值:X_4 AND X_5 AND X_6
X_8賦值:統計60日中滿足收盤價/1日前的收盤價>1.097的天數 AND (收盤價的250日簡單移動平均>=30日前的收盤價的250日簡單移動平均 OR 收盤價>收盤價的250日簡單移動平均) AND 收盤價的有效數據周期數>100
X_9賦值:上次X_7距今天數<=2 AND X_1 AND X_8
X_10賦值:485日內最高價的最高值的17日簡單移動平均
X_11賦值:222日內最高價的最高值的17日簡單移動平均
X_12賦值:96日內最高價的最高值的17日簡單移動平均
X_13賦值:485日內最低價的最低值的17日簡單移動平均
X_14賦值:222日內最低價的最低值的17日簡單移動平均
X_15賦值:96日內最低價的最低值的17日簡單移動平均
X_16賦值:(X_13*0.96+X_14*0.96+X_15*0.96+X_10*0.558+X_11*0.558+X_12*0.558)/6的17日簡單移動平均
X_17賦值:(X_13*1.25+X_14*1.23+X_15*1.2+X_10*0.55+X_11*0.55+X_12*0.65)/6的17日簡單移動平均
X_18賦值:(X_13*1.3+X_14*1.3+X_15*1.3+X_10*0.68+X_11*0.68+X_12*0.68)/6的17日簡單移動平均
X_19賦值:(X_16*3+X_17*2+X_18)/6*1.738的17日簡單移動平均
X_20賦值:如果1<=1341231,返回X_19,否則返回X_19*日
X_21賦值:最低價
X_22賦值:1日前的最低價
X_23賦值:X_21-X_22的絕對值的3日[1日權重]移動平均/X_21-X_22和0的較大值的3日[1日權重]移動平均*100
X_24賦值:如果收盤價*1.35<=X_20,返回X_23*10,否則返回X_23/10的3日簡單移動平均
X_25賦值:30日內最低價的最低值
X_26賦值:30日內X_24的最高值
X_27賦值:13412319
X_28賦值:如果1<=X_27,返回如果最低價<=X_25,返回(X_24+X_26*2)/2,否則返回0的3日簡單移動平均,否則返回100000000
X_29賦值:2日前的X_28>3日前的X_28 AND X_28<1日前的X_28
X_9 AND X_29

股票公式推薦
個股查股導航:股票行情查詢 DDX在線查詢 超贏數據查詢 資金流向 千股千評 個股最新消息 大小非解禁 十大股東查詢 分紅配股查詢 業績預告查詢
藍海華騰 300484+4.75% 千股千評 DDX指標 超贏 資金 大小非 股東 分紅
泉峰汽車 603982+4.74% 千股千評 DDX指標 超贏 資金 大小非 股東 分紅
太陽能 000591+4.73% 千股千評 DDX指標 超贏 資金 大小非 股東 分紅
金杯電工 002533+4.71% 千股千評 DDX指標 超贏 資金 大小非 股東 分紅
德業股份 605117+4.69% 千股千評 DDX指標 超贏 資金 大小非 股東 分紅
天原股份 002386+4.69% 千股千評 DDX指標 超贏 資金 大小非 股東 分紅
三德科技 300515+4.69% 千股千評 DDX指標 超贏 資金 大小非 股東 分紅
江蘇索普 600746+4.67% 千股千評 DDX指標 超贏 資金 大小非 股東 分紅
*ST香梨 600506+4.67% 千股千評 DDX指標 超贏 資金 大小非 股東 分紅
珠海中富 000659+4.65% 千股千評 DDX指標 超贏 資金 大小非 股東 分紅
手機版(手機訪問當前頁面) | 手機APP下載 | 電腦端(適合電腦或大屏用戶)
商務合作:在線客服
愛查股網不推薦股票,不收會員,網站內的廣告不代表本股票網的觀點,由此引起的一切法律責任均與本站無關,股市有風險,投資需謹慎。
特別提示:本站不為所提供數據的錯誤、殘缺、延遲或因依靠此信息所采取的任何行為負責。本股票網提供的所有內容僅供參考,不構成投資建議,投資者據此操作,風險自擔。
大龄熟妇特黄A片