愛查股網 www.suo-yin.cn 股票查詢最好股票網 個股數據查詢好股網 手機APP下載 | 手機訪問 | 加入收藏 | 保存到桌面
愛查股網
股票查詢最好股票網 個股數據查詢好股網
您的位置:愛查股網 > 股票公式 > 同花順公式
股票公式搜索:

同花順MACD三重背離指標公式

2021/8/19 20:11:58

DIF:EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:EMA(DIF,9);
MACD:(DIF-DEA)*2,COLORSTICK;
JCCOUNT:=COUNT(CROSS(DIF,DEA),BARSLAST(DEA>=0));
二次金叉:=CROSS(DIF,DEA) AND DEA<0 AND COUNT(JCCOUNT=2,21)=1;
DRAWTEXT(二次金叉,DEA*1.25,'零下二金'),colorwhite;
A1:=BARSLAST(REF(CROSS(DIF,DEA),1));
底背離:=REF(CLOSE,A1+1)>CLOSE AND DIF>REF(DIF,A1+1) AND CROSS(DIF,DEA);
DRAWTEXT(底背離,DIF*0.5,'日底背'),colorred;
A2:=BARSLAST(REF(CROSS(DEA,DIF),1));
頂背離:=REF(CLOSE,A2+1)<CLOSE AND REF(DIF,A2+1)>DIF AND CROSS(DEA,DIF);
DRAWTEXT(頂背離,DIF*1.12,'日頂背'),colorgreen;
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9));
K:=SMA(RSV,9,3),NODRAW;
D:=SMA(K,9,3),NODRAW;
J:=3*K-2*D,NODRAW;
M&K金共:=CROSS(DIF,DEA) AND CROSS(K,D) AND CROSS(J,D);
DRAWTEXT(M&K金共,DEA*1.12,'金叉共振'),coloryellow;
MACD高:=HHV(MACD,5);
C1:=BARSLAST(REF(CROSS(DEA,DIF),1));
E:=REF(C,C1+1)>C AND DEA>0 AND REF(MACD高,C1+1)<MACD高 AND CROSS(DEA,DIF) ;
DRAWTEXT(E>0,-0.5,'柱頂背'),colorcyan;
F:=REF(C,A1+1)>C AND DEA<0 AND REF(MACD高,A1+1)<MACD高 AND CROSS(DIF,DEA);
DRAWTEXT(F>0,0.5,'柱底背'),colorlired;
JC:= DEA-DIF;
綠柱面積:=IF(MACD<0,SUM(MACD,BARSLAST(JC<0)),0);
紅柱面積:=IF(MACD>0,SUM(MACD,BARSLAST(JC>0)),0);
本次最低價:=LLV(L,BARSLAST(JC<0));
本次最高價:=HHV(H,BARSLAST(JC>0));
X1:=IF (MACD<0,BARSLAST(CROSS(DIF,DEA)),0);
前次綠柱面積:=REF(綠柱面積,X1+1);
前次最低價:=REF(本次最低價,X1+1);
Y1:=IF((綠柱面積<0 AND ABS(綠柱面積)<ABS(前次綠柱面積) AND 本次最低價<前次最低價 ),1,0);
RS1:= MACD<0 AND REF(MACD,1)<0 AND C<前次最低價
AND ABS(綠柱面積)<ABS(前次綠柱面積) AND ABS(MACD)<ABS(REF(MACD,1));
底背馳:= IF (CROSS(DIF,DEA),REF(Y1,1),0);
DRAWTEXT(底背馳,DEA*0.8,'積底背'),COLORFF80FF;
X2:=IF (MACD>0,BARSLAST(CROSS(DEA,DIF)),0);
前次紅柱面積:=REF(紅柱面積,X2+1);
前次最高價:=REF(本次最高價,X2+1);
Y2:=IF((紅柱面積>0 AND 紅柱面積<前次紅柱面積 AND 本次最高價>前次最高價 ),1,0);
RS2:= MACD>0 AND REF(MACD,1)>0 AND C>前次最高價 AND ABS(紅柱面積)<ABS(前次紅柱面積) AND ABS(MACD)<ABS(REF(MACD,1));
頂背馳:= IF (CROSS(DEA,DIF),REF(Y2,1),0);
DRAWTEXT(頂背馳,DEA*0.8,'積頂背'),colorcyan;

愛查股 網 www.aichagu.co m

股票公式推薦
個股查股導航:股票行情查詢 DDX在線查詢 超贏數據查詢 資金流向 千股千評 個股最新消息 大小非解禁 十大股東查詢 分紅配股查詢 業績預告查詢
中礦資源 002738+4.10% 千股千評 DDX指標 超贏 資金 大小非 股東 分紅
招商輪船 601872+4.10% 千股千評 DDX指標 超贏 資金 大小非 股東 分紅
科沃斯 603486+4.09% 千股千評 DDX指標 超贏 資金 大小非 股東 分紅
中信國安 000839+4.09% 千股千評 DDX指標 超贏 資金 大小非 股東 分紅
龍磁科技 300835+4.08% 千股千評 DDX指標 超贏 資金 大小非 股東 分紅
正弦電氣 688395+4.07% 千股千評 DDX指標 超贏 資金 大小非 股東 分紅
元祖股份 603886+4.07% 千股千評 DDX指標 超贏 資金 大小非 股東 分紅
水晶光電 002273+4.07% 千股千評 DDX指標 超贏 資金 大小非 股東 分紅
雅本化學 300261+4.06% 千股千評 DDX指標 超贏 資金 大小非 股東 分紅
江化微 603078+4.05% 千股千評 DDX指標 超贏 資金 大小非 股東 分紅
手機版(手機訪問當前頁面) | 手機APP下載 | 電腦端(適合電腦或大屏用戶)
商務合作:在線客服
愛查股網不推薦股票,不收會員,網站內的廣告不代表本股票網的觀點,由此引起的一切法律責任均與本站無關,股市有風險,投資需謹慎。
特別提示:本站不為所提供數據的錯誤、殘缺、延遲或因依靠此信息所采取的任何行為負責。本股票網提供的所有內容僅供參考,不構成投資建議,投資者據此操作,風險自擔。
大龄熟妇特黄A片