愛查股網 www.suo-yin.cn 股票查詢最好股票網 個股數據查詢好股網 手機APP下載 | 手機訪問 | 加入收藏 | 保存到桌面
愛查股網
股票查詢最好股票網 個股數據查詢好股網
您的位置:愛查股網 > 股票公式 > 大智慧公式
股票公式搜索:

大智慧改良MACD指標公式

2021/5/3 16:50:49

SHORT:=12;
LONG:=26;
M:=9;
DIFF : EMA(CLOSE,SHORT) - EMA(CLOSE,LONG);
DEA : EMA(DIFF,M);
MACD : 2*(DIFF-DEA), COLORSTICK;
WW :MACD-REF(MACD,1),LINETHICK0;
低位死叉:=CROSS(DEA,DIFF) AND DIFF<0.02;
高位金叉:=CROSS(DIFF,DEA) AND DIFF>-0.02;
STICKLINE(低位死叉,DEA*0.86,DEA*0.66,6,0),COLORYELLOW;
DRAWTEXT(高位金叉,DEA*0.86,' 高金'),COLORFFFFFF;
STICKLINE(MACD<REF(MACD,1)AND MACD>0,0,MACD,3,0 ),COLOR00AAFF;
STICKLINE(MACD<REF(MACD,1)AND MACD>0,0,MACD,2.2,0 ),COLOR00BBFF;
STICKLINE(MACD<REF(MACD,1)AND MACD>0,0,MACD,1.8,0 ),COLOR00CCFF;
STICKLINE(MACD<REF(MACD,1)AND MACD>0,0,MACD,1.3,0 ),COLOR00DDFF;
STICKLINE(MACD<REF(MACD,1)AND MACD>0,0,MACD,0.9,0 ),COLOR00EEFF;
STICKLINE(MACD<REF(MACD,1)AND MACD>0,0,MACD,0.5,0 ),COLOR00FFFF;
STICKLINE(MACD>=REF(MACD,1)AND MACD>0,0,MACD,4 ,0 ),COLOR0000FF;
STICKLINE(MACD>=REF(MACD,1)AND MACD>0,0,MACD,3.3 ,0 ),COLOR0000FF;
STICKLINE(MACD>=REF(MACD,1)AND MACD>0,0,MACD,2.2,0 ),COLOR0000FF;
STICKLINE(MACD>=REF(MACD,1)AND MACD>0,0,MACD,1.65 ,0 ),COLOR0000FF;
STICKLINE(MACD>=REF(MACD,1)AND MACD>0,0,MACD,1.1 ,0 ),COLOR0000FF;
STICKLINE(MACD>=REF(MACD,1)AND MACD>0,0,MACD,0.55 ,0 ),COLOR0000FF;
STICKLINE(MACD>REF(MACD,1)AND MACD<0,0,MACD,4,0 ),COLORAA00BB;
STICKLINE(MACD>REF(MACD,1)AND MACD<0,0,MACD,3.3 ,0 ),COLORBB11BB;
STICKLINE(MACD>REF(MACD,1)AND MACD<0,0,MACD,2.2,0 ),COLORCC22BB;
STICKLINE(MACD>REF(MACD,1)AND MACD<0,0,MACD,1.65,0 ),COLORDD33BB;
STICKLINE(MACD>REF(MACD,1)AND MACD<0,0,MACD,1.1,0 ),COLOREE44BB;
STICKLINE(MACD>REF(MACD,1)AND MACD<0,0,MACD,0.55 ,0 ),COLORFF55BB;
STICKLINE(MACD<=REF(MACD,1)AND MACD<0,0,MACD,4,0 ),COLORFFAA00;
STICKLINE(MACD<=REF(MACD,1)AND MACD<0,0,MACD,3.3 ,0 ),COLORFFBB11;
STICKLINE(MACD<=REF(MACD,1)AND MACD<0,0,MACD,2.2,0 ),COLORFFCC22;
STICKLINE(MACD<=REF(MACD,1)AND MACD<0,0,MACD,1.65 ,0 ),COLORFFDD33;
STICKLINE(MACD<=REF(MACD,1)AND MACD<0,0,MACD,1.1 ,0 ),COLORFFEE44;
STICKLINE(MACD<=REF(MACD,1)AND MACD<0,0,MACD,0.55 ,0 ),COLORFFFF55;
IF(DIFF<0,DIFF,0),COLORRED,LINETHICK1;
IF(DIFF<0,0,DIFF),COLORYELLOW,LINETHICK1;
IF(DIFF<DEA,DIFF,DEA),COLOR00FF00,LINETHICK1;
IF(DIFF>DEA,DEA,DEA),COLORWHITE,LINETHICK1;
IF(DIFF<0,DIFF,0),COLORRED,LINETHICK1;
IF(DIFF<0,0,DIFF),COLORYELLOW,LINETHICK1;
IF(DIFF<DEA,DIFF,DEA),COLOR00FF00,LINETHICK1;
IF(DIFF>DEA,DEA,DEA),COLORWHITE,LINETHICK1;
操盤1號:=EMA(CLOSE,18) - EMA(CLOSE,34);
操盤2號:=EMA(操盤1號,4);
VAR1:=EMA(操盤1號,8);
VAR0:=2.2 * (操盤1號 - VAR1);
中期:=EMA(操盤1號,10);
STICKLINE(操盤2號 > 中期,操盤2號,中期,8,0),COLOR0000FF;
STICKLINE(操盤1號 < 操盤2號,操盤1號,操盤2號,8,0),COLORFFFFFF;

愛查股 網 www.aichagu.co m

股票公式推薦
個股查股導航:股票行情查詢 DDX在線查詢 超贏數據查詢 資金流向 千股千評 個股最新消息 大小非解禁 十大股東查詢 分紅配股查詢 業績預告查詢
天潤工業 002283+4.17% 千股千評 DDX指標 超贏 資金 大小非 股東 分紅
上海貝嶺 600171+4.15% 千股千評 DDX指標 超贏 資金 大小非 股東 分紅
艾力斯 688578+4.15% 千股千評 DDX指標 超贏 資金 大小非 股東 分紅
佳都科技 600728+4.15% 千股千評 DDX指標 超贏 資金 大小非 股東 分紅
景津環保 603279+4.14% 千股千評 DDX指標 超贏 資金 大小非 股東 分紅
諾德股份 600110+4.13% 千股千評 DDX指標 超贏 資金 大小非 股東 分紅
泰晶科技 603738+4.11% 千股千評 DDX指標 超贏 資金 大小非 股東 分紅
田中精機 300461+4.11% 千股千評 DDX指標 超贏 資金 大小非 股東 分紅
中礦資源 002738+4.10% 千股千評 DDX指標 超贏 資金 大小非 股東 分紅
招商輪船 601872+4.10% 千股千評 DDX指標 超贏 資金 大小非 股東 分紅
手機版(手機訪問當前頁面) | 手機APP下載 | 電腦端(適合電腦或大屏用戶)
商務合作:在線客服
愛查股網不推薦股票,不收會員,網站內的廣告不代表本股票網的觀點,由此引起的一切法律責任均與本站無關,股市有風險,投資需謹慎。
特別提示:本站不為所提供數據的錯誤、殘缺、延遲或因依靠此信息所采取的任何行為負責。本股票網提供的所有內容僅供參考,不構成投資建議,投資者據此操作,風險自擔。
大龄熟妇特黄A片